[Mulgara-general] Can't connect to remote Mulgara repository using ConnectionFactory [SOLVED]

Paul Gearon gearon at ieee.org
Fri Nov 21 16:13:26 UTC 2008

On Fri, Nov 21, 2008 at 6:03 AM, David Legg
<david.legg at searchevent.co.uk> wrote:
> Thanks also to Alex for suggesting the problem may be how the hostname
> is setup on the server and to Ron for giving me the clue how to spot
> it.  When I tried pinging the server from the server I got
> which is not only wrong... it is very wrong!
> So... thanks all round.

So, did that fix it for you?

> Paul,  I think based on this experience I'm wholly in favour of being
> able to eventually remotely access the full power of Mulgara through a
> RESTful web interface.  It is just so much more reliable, easier to
> setup, easier to protect with a firewall etc.

HTTP, yes. REST.... I'm not so sure about.

REST requires that a URL always returns the same data. Unfortunately,
if we have update operations on the database, then the returned data
can change. It is possible to put something like revision numbers into
the URL, but that would require keeping a lot of old revision states
available, which wouldn't be fun (mind you, we could give a "410 -
gone" response for anything that's dropped out. If you, or anyone
else, has idea, then please let me know. I'm the last person to ask
about REST, so I'm happy to take any and all advice.

The main thing missing from the HTTP setup is transactions. I don't
want to maintain state between calls, so I'm thinking I may need some
way to upload scripts to be run in a transaction. Any other ideas here
will be appreciated as well.


More information about the Mulgara-general mailing list