[Mulgara-dev] Axis

Chris Wilper cwilper at cs.cornell.edu
Fri Sep 29 20:00:12 UTC 2006


Paul,

For Fedora, we did the Axis upgrade (but only to 1.3, I believe) a while back
for
1.5 compatibility and it wasn't too painful.  Once the correct versions of
Axis'
dependent libs were in place, things worked as they had before.  YMMV for
Axis 1.4,
though.

- Chris

-----Original Message-----
From: mulgara-dev-bounces at mulgara.org on behalf of Paul Gearon
Sent: Fri 9/29/2006 3:51 PM
To: mulgara-dev at mulgara.org
Subject: [Mulgara-dev] Axis
 
Hi,

This is not a priority at all, but still....

Does anyone know Apache Axis?  Mulgara's descriptor code uses this for
generating servlets.  Unfortunately, our version of Axis (1.1) is not
Java 1.5 compatible, as it contains a package called "enum".  I'm
presuming that Axis 1.4 will be OK.

It's no problem for the moment, as I just have the Ant script
compiling this as Java 1.4 source code (which is it).  But it would be
nice to fix.

This is another one of those things that I don't really have the time
to correct, though it's probably a simple fix.  Ideally the new lib
will be a drop-in replacement, but I doubt it.  Anyone interested?

Paul
_______________________________________________
Mulgara-dev mailing list
Mulgara-dev at mulgara.org
http://mulgara.org/mailman/listinfo/mulgara-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mulgara.org/pipermail/mulgara-dev/attachments/20060929/3bd12d61/attachment.htm>


More information about the Mulgara-dev mailing list