[Mulgara-dev] Java 1.6

David Wood dwood at softwarememetics.com
Fri Sep 22 14:26:52 UTC 2006


+1 to deleting them.  They are, as I recall, an historical artifact  
of an attempt to write a JDBC driver.

Regards,
Dave

--
http://prototypo.blogspot.com


On 20 Sep2006, at 10:45, Paul Gearon wrote:

> Hi all,
>
> Since we don't have commercial pressures keeping Mulgara compatible
> with previous versions of Java, I've started making sure that Mulgara
> compiles and runs correctly on Java 1.6 (Beta).
>
> Unlike the 1.4 -> 1.5 transition, this one is MUCH easier.
>
> One of the required changes involves new interface requirements in the
> java.sql package, which needs changes in:
>  org.mulgara.query.AnswerWrapperResultSet
>  org.mulgara.util.AbstractResultSet
>  org.mulgara.util.AbstractMulgaraResultSet
>  org.mulgara.util.ResultSetMetaDataImpl
>  org.mulgara.util.TestResultSet
>
> These classes came about back when we wanted TKS/Kowari to have a JDBC
> adaptor, but we later determined that this is a bad idea.  So the
> classes are currently unused.
>
> It's easy enough to update the classes, but since they're unused I am
> about to delete them instead.  I just thought I'd ask in case someone
> has some compelling reason to resurrect them.
>
> (Incidentally, this is the only change needed to compile Mulgara on
> Java 1.6.  Some more changes are required to make all the tests pass).
>
> Regards,
> Paul
> _______________________________________________
> Mulgara-dev mailing list
> Mulgara-dev at mulgara.org
> http://mulgara.org/mailman/listinfo/mulgara-dev
>




More information about the Mulgara-dev mailing list